Urgent - prebuilt bug with recent update?

We get the following error when setting background to participants' videos as they join in daily prebuilt. We didn't change our code, but error started to appear.

"@daily-js:1 Uncaught (in promise) TypeError: Cannot read properties of undefined (reading 'useLegacyVideoProcessor')"

We do not use "useLegacyVideoProcessor" property. This error prevents from join completion.

I wonder if this has something to with the recent update with useLegavyVideoProcessor."

Best,

Tomo

«1

Answers

  • update

    we suspect that this happened because we did not define useLegacyVideoProcessor.

    So if there are users who didn't add this properties and updates the background, this error will appear.

  • mark_at_daily
    mark_at_daily Community Manager, Dailynista admin
    edited January 26

    @TomohiroMaeda can you please share detailed reproduction steps for this, including any configurations for the room or properties you initialize during createFrame? I'm asking because I'm unable to reproduce this issue and would like to see what you're doing so I can repro.

    Also, when you say: "when setting background to participants' videos as they join in daily prebuilt", do you mean that you select a background using the GUI in the precall lobby?

    Lastly, can you share a meeting session ID for one of these rooms, which will allow me to review the call logs for troubleshooting?

  • @mark_at_daily

    We lost which session it was, but here is the code we had.

    To create prebuilt frame, we use the code in the first image. Before resolving issue, we did not have the line 22-24.

    After a participant joined the meeting, we updated the background of the participant using the code in the second image.

    What happened was

    1. The code was working fine without the line 22-24.
    2. The code started to throw an error (but it was when the background was updated so it should not have been fatal for many. I suspect some of daily prebuilt users have issues updating the background though. We just defined join function which included the background, so that our join process was not recognized as completed and that restricted users some features we made outside of prebuilt)
    3. Adding line 22-24 resolved the error.

  • mark_at_daily
    mark_at_daily Community Manager, Dailynista admin

    Hmm, that's unexpected. I tried to reproduce this locally using all supported versions of daily-js and was unable to reproduce. What I tried was:

    • Load prebuilt in an iframe without useLegacyVideoProcessor specified in dailyConfig
    • Join a call
    • Start a background effect by providing an image URL to updateInputSettings().

    In all cases, this worked as expected with no error.

    Can you share which daily-js version you're using?

  • @mark_at_daily

    We just import daily.js with this.

    <script async src="https://unpkg.com/@daily-co/daily-js" crossorigin="anonymous"></script>

  • mark_at_daily
    mark_at_daily Community Manager, Dailynista admin

    Hmm, given that, I can't reproduce the issue. We haven't heard about this issue from any other customers either. For now, are you unblocked?

    If we find anything, I'll let you know.

  • @mark_at_daily

    I don't have any problems now, after we added dailyConfig lines. I just wanted to share as it started to give errors when we didn't change the deployed code, and thought others might experience the same issue.

  • mark_at_daily
    mark_at_daily Community Manager, Dailynista admin

    Good to hear! I'm glad that fixed things. I'm sorry I can't explain what's happening. We can't reproduce the issue and haven't received other reports. If anyone else hits this, we'll continue to investigate. Thank you 🙇

  • @mark_at_daily I just got an email from Sentry getting the same error

  • reeceatkinson
    reeceatkinson Member
    edited February 2

    @mark_at_daily it seems to happen when setting the strength of a background blur — if you want to reproduce I can give you a test link to our production call app to test: