Not able to stream video from URL in playwright tests

In my application, I am creating a custom track from the video which I get from the URL.
I am placing src={videoURL] for html video element. when I play the video, video starts downloading from the videoURL and I am collecting audio and video tracks and then creating custom tracks from them. when I run the application everything works fine. But when I run the playwright tests on this code, video doesn't download at all and I am getting this below error and its logs inside network tab in playwright test reports.

"URLhttps://randomURL/BigBuckBunny.mp4Request HeadersAccept: */*
Accept-Encoding: identity;q=1, *;q=0
Accept-Language: en-US
Origin: http://localhost:3000
Range: bytes=0-
Referer: http://localhost:3000/
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.5735.35 Safari/537.36Response HeadersContent-Length: 158008374
Content-Range: bytes 0-158008373/158008374
accept-ranges: bytes
access-control-allow-origin: *
access-control-expose-headers: Content-Length, Date, Server, Transfer-Encoding, X-GUploader-UploadID, X-Google-Trace, origin, range
alt-svc: h3=":443"; ma=2592000,h3-29=":443"; ma=2592000
cache-control: public, max-age=3600
content-type: video/mp4
date: Tue, 03 Oct 2023 10:58:58 GMT
etag: "cab08b36195edb1a1231d2d09fa450e0"
expires: Tue, 03 Oct 2023 11:58:58 GMT
last-modified: Thu, 05 Dec 2013 18:43:53 GMT
server: UploadServer
x-goog-generation: 1386269033518000
x-goog-hash: crc32c=x4GOmQ==
x-goog-hash: md5=yrCLNhle2xoSMdLQn6RQ4A==
x-goog-metageneration: 2
x-goog-storage-class: STANDARD
x-goog-stored-content-encoding: identity
x-goog-stored-content-length: 158008374
x-guploader-uploadid: ADPycdsUelXCMYTdmzflxHsIt4LaOL98CLJ1u8SDYM6F9X0l-h3cE4pIRuBE3OMIZeIMCatKTBWg1IpMOAx3mXQzW4P9KoCWOamVResponse BodyResponse body is not available for this request."


  • Tasha
    Tasha Community Manager, Dailynista admin

    Hi @svm_agilis

    I'm not super familiar with Playwright, but I'm wondering if this error appears only if you run locally. Are running the tests locally critical to your development flow?

    If so, can you point us to a codepen or code snippet that you are using to run the test so that our engineers can investigate?

    If you don't want to provide that publicly, that is totally fine! In that case, you can send the info to [email protected].