How to improve screenAudio quality while sharing screen

svm_agilis
svm_agilis Member
edited October 2022 in Q&A 🤔

I have enable sharing audio while sharing screen. but this audio that is shared along with the screen losses some quality. is there a way that I can improve this screenSharing audio quality?

Thanks

Best Answer

Answers

  • Hi @karl Thanks

    I have set this micAudioMode to 'music' but I still see that in chrome://webrtc-internals screen audio uses only 32kbps. I have set this micAudioMode to 'music' in dailyConfig while creating callObject, is this the correct way of setting it. I think the micAudioMode which I set is not working. and also I want to change only screenAudio quality, does this micAudioMode applies to all the users audio?

  • Hi @karl Thanks

    constraints = {

    video: { width: 0, height: 0, frameRate: 0},

    audio: true

    };

    captureStream = await navigator.mediaDevices.getDisplayMedia(constraints);

    startScreenShare({ mediaStream: captureStream });


    DailyIframe.createCallObject({

    .......

    dailyConfig: {

    .......

    micAudioMode: 'music' ,

    ........

    }

    ...........

    })

    I have used the above code to share only audio through screenSharing. I can see that in chrome://webrtc-internals screen audio uses only 32kbps instead of 256kbps (when we set micAudioMode: 'music'). can you please tell me is there any mistake in the code and can you please also help me in imporving audio quality that is shared through screenShare?

  • Hi! Congratulations! You have stumbled into a daily bug. 🙈 Thank you for posting! The good news is we already had a fix in the works as part of a broader change to allow you to completely customize the bandwidth settings for audio tracks. If you would like a temporary work-around, change micAudioMode to musicMode in the dailyConfig you have above. BUT NOTE: When you upgrade to get the fix, musicMode will go away and you'll need to change it back to micAudioMode.

    Also note, make sure you are in SFU mode since these settings do not apply in the p2p configuration.

    I'll update this thread once the fix has been deployed + info on setting custom bandwidth settings if interested.

  • Hi...Thanks

    it worked when I use musicMode , I could see that in chrome://webrtc-internals screenAudio uses 256kbps. but this 256kbps bandwidth applies to all the users audio. is there a way I can set this musicMode / micAudioModez only to owner or specific user of the room ?

  • See here where I think you posed this question separately. Hopefully my answer there helps.

  • Hi....Thanks

    I have set micAudioMode: 'music' while creating callObject and it did not worked.

    Later I use musicMode: 'music' while creating callObject and it worked.

    but when use when I set micAudioMode: 'music'  in join() method and it did not work,

    and also I have checked with musicMode: 'music' in join() method and it also did not work

  • Tasha
    Tasha Community Manager, Dailynista admin

    Hi @svm_agilis I'm putting a link here to the other thread where your last question is discussed.

    You can follow up here as needed: https://community.daily.co/discussion/136/how-to-use-micaudiomode-music-in-join-method-while-joining#latest